Digital Note

Grab a coffe, take a seat, maybe listen to some music and relax by reading our digital daily diary. We want to share our minds and know how with you and the whole world!

Blog phones

Failover Mikrotik dengan 2 Koneksi

Teknik Failover adalah suatu teknik jaringan dengan memberikan dua jalur koneksi atau lebih dimana ketika salah satu jalur mati, maka koneksi masih tetap berjalan dengan dialihkan ke jalur lainnya. Teknik failover ini cukup penting ketika kita menginginkan adanya koneksi jaringan internet yang handal dan minimal disconnect dari internet. Teknik ini biasa dilakukan pada perusahaan dimana kegiatannya sangat bergantung pada layanan internet, tapi tidak menutup kemungkinan bahwa perusahaan/lembaga kecil juga bisa membutuhkan hal seperti ini.

Tutorial Failover mikrotik dengan 2 Koneksi Internet yang akan saya bahas kali ini sedikit spesial, karena bukan seperti failover yang biasanya banyak digunakan. Jadi disini saya akan membuat jaringan internet dengan menggunakan 2 koneksi, yaitu koneksi utama menggunakan ISP dan koneksi cadangan dengan Modem USB. Secara umum topologi jaringannya seperti berikut:

failover_topologi

Teknik failover yang akan saya gunakan kali ini adalah dengan membuat koneksi dari ISP sebagai Jalur utama dan ketika jalur utama mati (down) maka koneksi akan langsung pindah ke jalur cadangan. Jika koneksi utama kembali normal (up) maka koneksi akan kembali pindah ke jalur utama. Hal ini tidak dapat dilakukan dengan menggunakan teknik Failover biasa yang hanya menggunakan ping check gateway pada Route.

Untuk menerapkan teknik ini saya menggunakan perpaduan beberapa tools di Mikrotik, yakni Script, Netwatch, dan Check gateway pada Route. Oke langsung saja menuju Tutorial Failover Mikrotik dengan 2 Koneksi Internet. Disini saya tidak akan membahas caranya dari awal, tapi langsung ke inti cara failover-nya.

  1. Pastikan kedua koneksi internet yang akan anda gunakan sudah berjalan dengan baik di Mikrotik.
  2. Masuk ke System –> Script –> Add. Tambahkan 2 Script Mikrotik berikut:

    Script Failover:

    :if ([/ip route get [/ip route find comment="utama"] disabled]=yes) do={/ip route enable [/ip route find comment="utama"]} else={/ip route disable [/ip route find comment="utama"]}

    failover_1

    Script kembali ke jalur utama:

    :if ([/ip route get [/ip route find comment="utama"] disabled]=yes) do={/ip route enable [/ip route find comment="utama"]}

    failover_2_back-main

  3. Buat rule Netwatch. Masuk ke Tools –> Netwatch –> Add. Buat dua rule berikut:

    Netwatch Failover:

    [Tab Host]
    – Host : 8.8.8.8
    – Interval : 00:00:03
    – Timeout : 1000 ms[Tab Down]
    – On Down : failover (sesuaikan dengan nama script nya)

    failover_3_netwatch

    Netwatch Kembali ke jalur utama:

    [Tab Host]
    – Host : 8.8.8.8
    – Interval : 00:00:03
    – Timeout : 1000 ms

    [Tab Up]
    On Up: back2main (sesuaikan dengan nama script nya)

    failover_3_netwatch-back-main

  4. Edit tabel routing mikrotik. Masuk ke IP –> Routes. Buat seperti gambar berikut ini:

    failover_4_routelist

    Route untuk jalur utama:

    Buat secara manual route untuk jalur utama dengan konfigurasi:
    – Dst Address : 0.0.0.0/0
    – Gateway : ether1 (pilih interface yang terhubung ke jalur utama)
    – Distance : 1
    – Check Gateway : ping
    – Yang paling penting adalah buat comment. Klik menu Comment –> isikan : utama

    failover_5_route-utama

    Route untuk jalur cadangan:

    Buat secara manual route untuk jalur utama dengan konfigurasi:
    – Dst Address : 0.0.0.0/0
    – Gateway : smartfren (pilih interface yang terhubung ke jalur cadangan)
    – Distance : 2
    – Yang paling penting adalah buat comment. Klik menu Comment –> isikan : cadangan

    Route untuk ping netwatch:

    Buat route untuk jalur ping Netwatch dengan konfigurasi:
    – Dst Address : 0.0.0.0/0
    – Gateway : ether1 (pilih interface yang terhubung ke jalur utama)
    – Distance : 1

  5. Konfigurasi sudah selesai.

Sekarang coba cek konfigurasi nya sudah bisa berjalan dengan baik apa belum. Caranya dengan lakukan ping ke google, dan coba matikan koneksi jalur utama. Jika konfigurasi benar, maka ping akan timeout untuk beberapa saat kemudian reply lagi yang mengindikasikan kalau failover bekerja. Hidupkan lagi koneksi jalur utama, maka jika konfigurasi benar, koneksi akan langsung berpindah kembali ke jalur utama.

 

Semoga Berhasil.

Trackback from your site.

Leave a comment