Digital Note

Grab a coffe, take a seat, maybe listen to some music and relax by reading our digital daily diary. We want to share our minds and know how with you and the whole world!

Blog phones

Mengamankan Mikrotik dari Serangan Denial of service attack (DOS)

Salah satu serangan yang dilakukan oleh attacker/hacker untuk melumpukan jaringan komputer adalah dengan melakukan serangan Denial of Service attack. Dimana serangan ini akan membanjiri trafik sehingga komputer/router akan menjadi terambil alih koneksinya kepada komputer yang melakukan serangan DoS sampai dimana proses dari komputer/router meningkat dan bisa mengakibatkan komputer/router menjadi crash. Akibatnya komputer/router target bisa tidak dapat beroperasi.

Pada router MikroTik anda dapat melakukan penanganan dengan cara membatasi koneksi dengan batas koneksi yang diperbolehkan dari suatu alamat IP(internet Protocol).Jadi tiap koneksi yang diterima (Incoming Connection) akan dibatasi dalam melakukan koneksi sehingga tidak akan menyebabkan router mikrotik kehabisan resource.

Langkah Konfigurasinya adalah sebagai berikut:
1. Login ke Router dengan menggunakan winbox
2. klik “New Terminal”. Ini akan membuka console mikrotik yang akan kita gunakan untuk melakukan konfigurasi.
3. Sebuah alamat IP dengan terlalu banyak koneksi akan ditambahkan ke daftar alamat untuk diblockir.ketik script berikut di terminal.

/ip firewall filter add chain=input protocol=tcp connection-limit=10,32 action=add-src-to-address-list address-list=blocked-addr address-list-timeout=1d

4. Bukan hanya menjatuhkan paket penyerang dengan ‘action = drop, router juga mengcapture dan menahan koneksi dan memperlambat penyerang drop. ketik script berikut di terminal.

/ip firewall filter add chain=input protocol=tcp src-address-list=blocked-addr connection-limit=8,32 action=tarpit

5. Kemudian melakukan penyaringan lanjut terhadap paket SYN. ketik script berikut di terminal.

/ip firewall filter add chain=forward protocol=tcp tcp-flags=syn connection-state=new action=jump jump-target=SYN-Protect comment="Melindungi dari serangan syn flooding" disabled=yes
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn limit=200,5 connection-state=new action=accept comment="" disabled=no
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn connection-state=new action=drop comment="" disabled=no

6. Dan yang terakhir ini adalah mengaktifkan SYN cookies
Mikrotik v6.x keatas

/ip settings set tcp-syncookies=yes

Mikrotik versi lama

/ip firewall connection tracking set tcp-syncookie=yes

Sumber : http://indefinitech.com/forum/Thread-mengamankan-mikrotik-dari-serangan-denial-of-service-attack-dos.html

Trackback from your site.

Leave a comment